Search Results for 'gtk'

1 POSTS

  1. 2009.11.24 glib-2.0 2.22.2 설치후 GTK+ configure시 에러

checking for dcgettext... yes
checking if msgfmt accepts -c... yes
checking for gmsgfmt... /usr/bin/msgfmt
checking for xgettext... /usr/bin/xgettext
checking for catalogs to be installed...  af am ang ar as ast az az_IR be be@latin bg bn bn_IN br bs ca ca@valencia crh cs cy da de dz el en_CA en_GB eo es et eu fa fi fr ga gl gu he hi hr hu hy ia id io is it ja ka kn ko ku li lt lv mai mi mk ml mn mr ms nb ne nl nn nso oc or pa pl ps pt pt_BR ro ru rw si sk sl sq sr sr@latin sr@ije sv ta te th tk tr tt uk ur uz uz@cyrillic vi wa xh yi zh_CN zh_HK zh_TW
checking for extra flags to get ANSI library prototypes... none needed
checking for the BeOS... no
checking for HP-UX... no
checking for extra flags for POSIX compliance... none needed
checking for pkg-config... (cached) /usr/bin/pkg-config
checking pkg-config is at least version 0.16... yes
checking for GLIB - version >= 2.21.3...
*** 'pkg-config --modversion glib-2.0' returned 2.22.2, but GLIB (2.16.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.21.3 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.


glib-2.0 2.22.2 를 설치한 후 GTK+ 2.18.3을 설치하려고 ./configure를 실행했더니

위와 같은 에러를 뱉어내면서 진행이 되지 않는다...


LD_LIBRARY_PATH는 환경변수에 있지도 않고, /etc/ld.so.conf 파일을 뒤져봐도

glib에 관련된 내용은 없다.


문득 ldconfig나 함 해볼까 하고 했더니....!!!! 지나간다.... ㅜ.ㅠ



신고

티스토리 툴바