I just built the distribution binary, and when I try to check out Subversion, I get an error about an "Unrecognized URL scheme." What's up with that?

Subversion uses a plugin system to allow access to repositories. Currently there are three of these plugins: ra_local allows access to a local repository, ra_neon or ra_serf which allow access to a repository via WebDAV, and ra_svn allows local or remote access via the svnserve server. When you attempt to perform an operation in Subversion, the program tries to dynamically load a plugin based on the URL scheme. A `file://' URL will try to load ra_local, and an `http://' URL will try to load ra_neon or ra_serf.

The error you are seeing means that the dynamic linker/loader can't find the plugins to load. For `http://' access, this normally means that you have not linked Subversion to neon or serf when compiling it (check the configure script output and the config.log file for information about this). It also happens when you build Subversion with shared libraries, then attempt to run it without first running 'make install'. Another possible cause is that you ran make install, but the libraries were installed in a location that the dynamic linker/loader doesn't recognize. Under Linux, you can allow the linker/loader to find the libraries by adding the library directory to /etc/ld.so.conf and running ldconfig. If you don't wish to do this, or you don't have root access, you can also specify the library directory in the LD_LIBRARY_PATH environment variable.


subversion을 1.6.6 으로 업그레이드 하면서 달랑 ./configure한 후에 make install 했더니...

위에 적은 것 처럼.... http:// 로 접근하는 저장소에서는 체크아웃이 안된다.... 쩝~

subversion을 빌드할때 ./configure --with-neon=/usr 옵션을 주고 컴파일을 해야 한다.

neon library가 /usr/lib 디렉토리 밑에 있길레,  ./configure --with-neon=/usr/lib로 했더니,

neon library를 못찾는다. neon 0.29.0 버전 다운로드 받는 곳을 가르쳐 주면서 다운받으란다.


다운로드 한 후에 또 컴파일을 해야 하는데... 이것두 그냥 ./configure만 하면 안된다... ㅜ.ㅡ

./configure 시에 --enable-shared 옵션을 주어야 한다. 디폴트는 no 이기 때문이다. ㅠ.ㅠ


이렇게 컴파일을 하고 make install을 하면 라이브러리가 설치되고....

다시 subversion configure를 하는데... 위에 적은 겇처럼... ./configure --with-neon=/usr/lib 가 아니고

./configure --with-neon=/usr 로 해야 한다.


그런 다음... make install 하면 끝!!!! ㅡ.ㅡ


신고

'Research > Tools' 카테고리의 다른 글

qt embedded 4.6 configure option  (0) 2009.12.29
CFE setenv  (0) 2009.12.22
uclinux-rootfs  (0) 2009.12.17
svn: Unrecognized URL scheme for 'http://.......'  (0) 2009.12.03
SVN: Store password unencrypted (yes/no)?  (6) 2009.12.03
qt embedded compile시 libpng관련 에러  (0) 2009.11.30
« PREV : 1 : ··· : 73 : 74 : 75 : 76 : 77 : 78 : 79 : 80 : 81 : ··· : 536 : NEXT »

티스토리 툴바